re = /<td\s.*?>.*?<span\s.*?>(.*?)<\/span><\/td>/m
str = '<td id="yiv9101838563i4" style="padding:0;padding-top:25px;font-family:\'Segoe UI\', Tahoma, Verdana, Arial, sans-serif;font-size:14px;color:#2a2a2a;">Security code: <span style="font-family:\'Segoe UI Bold\', \'Segoe UI Semibold\', \'Segoe UI\', \'Helvetica Neue Medium\', Arial, sans-serif;font-size:14px;font-weight:bold;color:#2a2a2a;">7201</span></td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end