#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{((?:[^{}]*\{[^{}]*\})*[^}]*)\}"
Local $sString = "<html>" & @CRLF & _
"<head>" & @CRLF & _
" <title>DailyHoroscope.com</title>" & @CRLF & _
" <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">" & @CRLF & _
" {if $contact['timezone']} " & @CRLF & _
" {assign var=local_tz value=$contact['timezone']} " & @CRLF & _
" {else} " & @CRLF & _
" {assign var=local_tz value='America/New_York'} " & @CRLF & _
" {/if} " & @CRLF & _
" {assign var=tracking_params value="utm_medium={$medium}&utm_source={$source}&utm_campaign={$campaign}"}" & @CRLF & _
"</head>" & @CRLF & _
"<body style="background:#fff;">" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")