const regex = /\{((?:[^{}]*\{[^{}]*\})*[^}]*)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{((?:[^{}]*\\{[^{}]*\\})*[^}]*)\\}', 'g')
const str = `<html>
<head>
<title>DailyHoroscope.com</title>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=UTF-8">
{if \$contact['timezone']}
{assign var=local_tz value=\$contact['timezone']}
{else}
{assign var=local_tz value='America/New_York'}
{/if}
{assign var=tracking_params value="utm_medium={\$medium}&utm_source={\$source}&utm_campaign={\$campaign}"}
</head>
<body style="background:#fff;">
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}