# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\?[^?])*))\?>"
test_str = ("<?php \n"
"$lang=JFactory::getLanguage()->getLang(); \n"
" $lang=substr($lang,0,2).>;if ($l<<<<>>>>ang=='uk')\n"
" $lang='ua';\n"
" echo JRoute::_(\"index.php?option=zzp?com_sim&layout=pedaski&limit=1&limitstart=1&view=pedagogie&lang=courchevel-$lang\");?> <>\n\n"
" <?php zdezf . \n"
"ssasa dns\n"
"dzdn\n\n"
" echo JText::_(\"PEDAEQUIP\");?></a>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.