re = /<\?php((?:(?:(?!php)[^?]>|(?!php)[^?]|...\?[^?])*))\?>/
str = '<?php
$lang=JFactory::getLanguage()->getLang();
$lang=substr($lang,0,2).>;if ($l<<<<>>>>ang==\'uk\')
$lang=\'ua\';
echo JRoute::_("index.php?option=zzp?com_sim&layout=pedaski&limit=1&limitstart=1&view=pedagogie&lang=courchevel-$lang");?> <>
<?php zdezf .
ssasa dns
dzdn
echo JText::_("PEDAEQUIP");?></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end