package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+(gif|png|jpg)$`)
var str = `abc.png
bcd.jpg
a.xyz
b.exe
a.png.bs.jpg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}