$re = '/^.+(gif|png|jpg)$/m';
$str = 'abc.png
bcd.jpg
a.xyz
b.exe
a.png.bs.jpg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);