using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^random|(0|27)\d{9}$";
string input = @"0821234567
27821234567
random
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}