$re = '/^random|(0|27)\d{9}$/m';
$str = '0821234567
27821234567
random
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);