package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<tag>.*?<\/tag>|[^<>]+`)
var str = `The quick brown <tag>fox</tag> jumps over the lazy <tag>dog</tag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}