$re = '/<tag>.*?<\/tag>|[^<>]+/m';
$str = 'The quick brown <tag>fox</tag> jumps over the lazy <tag>dog</tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);