import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\TSY\\|(?P<timeRef>[0-9].)\\s(?P<timeTag>[0-9]*)";
final String string = "1555501525 fffffffe rms Trsm Primary bitMaintLog 'TR_Rare TSY|82 1555501525' BitMaintLog.c 642 CS_addMaintLogEnt\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}