# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\TSY\|(?P<timeRef>[0-9].)\s(?P<timeTag>[0-9]*)"
test_str = ("1555501525 fffffffe rms Trsm Primary bitMaintLog 'TR_Rare TSY|82 1555501525' BitMaintLog.c 642 CS_addMaintLogEnt\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.