use strict;
my $str = '/^(?=.{173}\\Q\\2\\)){2}.{11}$\\E\\/\\z)((?=(.2.|))\\2\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{173}\\2\\\\Q\\2\\\\2\\2\\\\\\2\\)\\2\\)\\2\\{2}\\2\\.\\2\\{11}\\2\\$\\2\\\\E\\2\\\\\\2\\/\\2\\\\z\\2\\)\\2\\(\\2\\(\\2\\?=\\2\\(\\2\\.2\\2\\.\\2\\|\\2\\)\\2\\)){2}.{11}$/';
my $regex = qr/^(?=.{173}\Q\2\)){2}.{11}$\E\/\z)((?=(.2.|))\2\/\2\^\2\(\2\?=\2\.\2\{173}\2\\Q\2\\2\2\\\2\)\2\)\2\{2}\2\.\2\{11}\2\$\2\\E\2\\\2\/\2\\z\2\)\2\(\2\(\2\?=\2\(\2\.2\2\.\2\|\2\)\2\)){2}.{11}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}