re = /^(?=.{173}\Q\2\)){2}.{11}$\E\/\z)((?=(.2.|))\2\/\2\^\2\(\2\?=\2\.\2\{173}\2\\Q\2\\2\2\\\2\)\2\)\2\{2}\2\.\2\{11}\2\$\2\\E\2\\\2\/\2\\z\2\)\2\(\2\(\2\?=\2\(\2\.2\2\.\2\|\2\)\2\)){2}.{11}$/
str = '/^(?=.{173}\\Q\\2\\)){2}.{11}$\\E\\/\\z)((?=(.2.|))\\2\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{173}\\2\\\\Q\\2\\\\2\\2\\\\\\2\\)\\2\\)\\2\\{2}\\2\\.\\2\\{11}\\2\\$\\2\\\\E\\2\\\\\\2\\/\\2\\\\z\\2\\)\\2\\(\\2\\(\\2\\?=\\2\\(\\2\\.2\\2\\.\\2\\|\\2\\)\\2\\)){2}.{11}$/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end