package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(.+)+\,+\#+\w{6}`)
var str = `Acanthocolla_cruciata,#8B5F65Acanthocyrta_haeckeli,#8B5F65Acanthometra_fusca,#8B5F65Acanthopeltis_japonica,#FFB5C5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}