re = /(.+)+\,+\#+\w{6}/
str = 'Acanthocolla_cruciata,#8B5F65Acanthocyrta_haeckeli,#8B5F65Acanthometra_fusca,#8B5F65Acanthopeltis_japonica,#FFB5C5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end