package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:b[^a-zA-Z]*?a[^a-zA-Z]*?s[^a-zA-Z]*?e)|(?:d[^a-zA-Z]*?e[^a-zA-Z]*?c[^a-zA-Z]*?o[^a-zA-Z]*?d[^a-zA-Z]*?e)`)
var str = `'ba'.'se'.(32*2).'_d'.'eco'.'de'
or
'b'.'as'.'e6'.'4_d'.'ec'.'ode';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}