$re = '/(?:b[^a-zA-Z]*?a[^a-zA-Z]*?s[^a-zA-Z]*?e)|(?:d[^a-zA-Z]*?e[^a-zA-Z]*?c[^a-zA-Z]*?o[^a-zA-Z]*?d[^a-zA-Z]*?e)/m';
$str = '\'ba\'.\'se\'.(32*2).\'_d\'.\'eco\'.\'de\'
or
\'b\'.\'as\'.\'e6\'.\'4_d\'.\'ec\'.\'ode\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);