package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)""*[^"]*"*"`)
var str = `If cmd = "History Report" Then
Range("D2").Formula = "=TEXT(""" & createDate & """,""" & Replace(subtitleFormat, """", """""") & """)"
comment = "This task is completed!"
End If`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}