$re = '/(<\s*img\s+[^>]*src\s*=\s*[\"\'])(?!(http)|(\/\/))([^\"\'>]+)([\"\'>]+)/';
$str = '<img src="//domain.com/file.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);