re = /(<\s*img\s+[^>]*src\s*=\s*[\"'])(?!(http)|(\/\/))([^\"'>]+)([\"'>]+)/
str = '<img src="//domain.com/file.jpg">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end