const regex = /^(((((((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?)|(((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?"((\s? +)?(([!#-[\]-~])|(\\([ -~]|\s))))*(\s? +)?"))?)?(((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?<(((((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?(([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+(\.([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+)*)((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?)|(((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?"((\s? +)?(([!#-[\]-~])|(\\([ -~]|\s))))*(\s? +)?"))@((((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?(([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+(\.([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+)*)((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?)|(((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?\[((\s? +)?([!-Z^-~]))*(\s? +)?\]((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?)))>((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?))|(((((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?(([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+(\.([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+)*)((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?)|(((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?"((\s? +)?(([!#-[\]-~])|(\\([ -~]|\s))))*(\s? +)?"))@((((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?(([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+(\.([A-Za-z0-9!#-'*+\/=?^_`{|}~-])+)*)((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?)|(((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?\[((\s? +)?([!-Z^-~]))*(\s? +)?\]((((\s? +)?(\(((\s? +)?(([!-'*-[\]-~]*)|(\\([ -~]|\s))))*(\s? +)?\)))(\s? +)?)|(\s? +))?))))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((((((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?)|(((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?"((\\s? +)?(([!#-[\\]-~])|(\\\\([ -~]|\\s))))*(\\s? +)?"))?)?(((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?<(((((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?(([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+(\\.([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+)*)((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?)|(((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?"((\\s? +)?(([!#-[\\]-~])|(\\\\([ -~]|\\s))))*(\\s? +)?"))@((((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?(([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+(\\.([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+)*)((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?)|(((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?\\[((\\s? +)?([!-Z^-~]))*(\\s? +)?\\]((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?)))>((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?))|(((((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?(([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+(\\.([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+)*)((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?)|(((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?"((\\s? +)?(([!#-[\\]-~])|(\\\\([ -~]|\\s))))*(\\s? +)?"))@((((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?(([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+(\\.([A-Za-z0-9!#-\'*+\\\/=?^_`{|}~-])+)*)((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?)|(((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?\\[((\\s? +)?([!-Z^-~]))*(\\s? +)?\\]((((\\s? +)?(\\(((\\s? +)?(([!-\'*-[\\]-~]*)|(\\\\([ -~]|\\s))))*(\\s? +)?\\)))(\\s? +)?)|(\\s? +))?))))$', '')
const str = `"Foo Bar" <foo.bar@baz.com>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}