import re
regex = re.compile(r"(\[\[.+?)\/(.+?\]\])", flags=re.MULTILINE)
test_str = "[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]"
subst = "$1#$2"
result = regex.sub(subst, test_str)
if result:
print(result)