re = /(\[\[.+?)\/(.+?\]\])/m
str = '[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]'
subst = '$1#$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result