import re
regex = re.compile(r"1-0:1.8.2\(([0-9]{1,96}).([0-9]{1,96}).*(kWh)", flags=re.MULTILINE)
test_str = ("/KFM5KAIFA-METER\n\n"
"1-3:0.2.8(42)\n"
"0-0:1.0.0(230312193138W)\n"
"0-0:96.1.1(4530303235313030303635313836373136)\n"
"1-0:1.8.1(010971.897*kWh)\n"
"1-0:1.8.2(016085.943*kWh)\n"
"1-0:2.8.1(000000.000*kWh)\n"
"1-0:2.8.2(000000.000*kWh)\n"
"0-0:96.14.0(0001)\n"
"1-0:1.7.0(00.404*kW)\n"
"1-0:2.7.0(00.000*kW)\n"
"0-0:96.7.21(00003)\n"
"0-0:96.7.9(00004)\n"
"1-0:99.97.0(5)(0-0:96.7.19)(221209092021W)(0000004031*s)(210314223749W)(0000000455*s)(210207175517W)(0000003289*s)(180331043234S)(0000000398*s)(000101000001W)(2147483647*s)\n"
"1-0:32.32.0(00000)\n"
"1-0:32.36.0(00000)\n"
"0-0:96.13.1()\n"
"0-0:96.13.0()\n"
"1-0:31.7.0(002*A)\n"
"1-0:21.7.0(00.390*kW)\n"
"1-0:22.7.0(00.000*kW)\n"
"!2284\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")