import Foundation
let pattern = #"1-0:1.8.2\(([0-9]{1,96}).([0-9]{1,96}).*(kWh)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/KFM5KAIFA-METER
1-3:0.2.8(42)
0-0:1.0.0(230312193138W)
0-0:96.1.1(4530303235313030303635313836373136)
1-0:1.8.1(010971.897*kWh)
1-0:1.8.2(016085.943*kWh)
1-0:2.8.1(000000.000*kWh)
1-0:2.8.2(000000.000*kWh)
0-0:96.14.0(0001)
1-0:1.7.0(00.404*kW)
1-0:2.7.0(00.000*kW)
0-0:96.7.21(00003)
0-0:96.7.9(00004)
1-0:99.97.0(5)(0-0:96.7.19)(221209092021W)(0000004031*s)(210314223749W)(0000000455*s)(210207175517W)(0000003289*s)(180331043234S)(0000000398*s)(000101000001W)(2147483647*s)
1-0:32.32.0(00000)
1-0:32.36.0(00000)
0-0:96.13.1()
0-0:96.13.0()
1-0:31.7.0(002*A)
1-0:21.7.0(00.390*kW)
1-0:22.7.0(00.000*kW)
!2284
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)