package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w{3}\b`)
var str = `dad asdasa asdas asdhhgfh dfgdfdasa ttte aa1 asasda aa2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}