$re = '/\b\w{3}\b/';
$str = 'dad asdasa asdas asdhhgfh dfgdfdasa ttte aa1 asasda aa2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);