using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(35|38|51|52)[0-9]{3}";
string input = @"51002";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}