$re = '/(35|38|51|52)[0-9]{3}/';
$str = '51002';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);