#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)(?:(?:20\d{2})(?:(?:(?:0[13578]|1[02])31)|(?:(?:0[1,3-9]|1[0-2])(?:29|30)))|(?:(?:20(?:0[48]|[2468][048]|[13579][26]))0229)|(?:20\d{2})(?:(?:0?[1-9])|(?:1[0-2]))(?:0?[1-9]|1\d|2[0-8]))(?!\d)"
Local $sString = "aaa_20150229_bbb" & @CRLF & _
"aaa_20120229_bbb" & @CRLF & _
"aaa_20000229_bbb" & @CRLF & _
"aaa_19000229_bbb" & @CRLF & _
"aaa_18000229_bbb" & @CRLF & _
"aaa_17000229_bbb" & @CRLF & _
"aaa_16000229_bbb" & @CRLF & _
"" & @CRLF & _
"aaa_20150130_bbb" & @CRLF & _
"aaa_20150131_bbb" & @CRLF & _
"aaa_20150430_bbb" & @CRLF & _
"aaa_20150431_bbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")