import re
regex = re.compile(r"(?<!\d)(?:(?:20\d{2})(?:(?:(?:0[13578]|1[02])31)|(?:(?:0[1,3-9]|1[0-2])(?:29|30)))|(?:(?:20(?:0[48]|[2468][048]|[13579][26]))0229)|(?:20\d{2})(?:(?:0?[1-9])|(?:1[0-2]))(?:0?[1-9]|1\d|2[0-8]))(?!\d)", flags=re.MULTILINE)
test_str = ("aaa_20150229_bbb\n"
"aaa_20120229_bbb\n"
"aaa_20000229_bbb\n"
"aaa_19000229_bbb\n"
"aaa_18000229_bbb\n"
"aaa_17000229_bbb\n"
"aaa_16000229_bbb\n\n"
"aaa_20150130_bbb\n"
"aaa_20150131_bbb\n"
"aaa_20150430_bbb\n"
"aaa_20150431_bbb")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")