$re = '/(?:ПОДВАЛ|(?!^)\G).*?\K(КИРПИЧ)(?=(?(?=ПОДВАЛ)|.)*?КРЫША)/';
$str = 'КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);