re = /(?:ПОДВАЛ|(?!^)\G).*?\K(КИРПИЧ)(?=(?(?=ПОДВАЛ)|.)*?КРЫША)/
str = 'КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ ПОДВАЛ дверь КИРПИЧ дверь окно КИРПИЧ КРЫША труба КИРПИЧ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end