import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[sc]/(?:ABS|servo|ESP|válvula)\\b";
final String string = "12222/133-164 s/ABS s/abs s/A s/a puerta s/ESP s/servo s/a 4/5,hola s/s / r,147 / Spazio / Vivace, Tiida 1.8 - Visia/Acenta s/B, c/válvula";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}