import Foundation
let pattern = #"\b[sc]/(?:ABS|servo|ESP|válvula)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"12222/133-164 s/ABS s/abs s/A s/a puerta s/ESP s/servo s/a 4/5,hola s/s / r,147 / Spazio / Vivace, Tiida 1.8 - Visia/Acenta s/B, c/válvula"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)