using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?[ '-]{2})[A-Za-z '-]{1,20}$";
string input = @"John Doe
John-Doe
John'Doe
-JohnDoe
John Doe-
'John Doe
John Doe'
John--Doe
John''Doe
John Doe
John'-Doe
John' Doe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}