re = /^(?!.*?[ '-]{2})[A-Za-z '-]{1,20}$/m
str = 'John Doe
John-Doe
John\'Doe
-JohnDoe
John Doe-
\'John Doe
John Doe\'
John--Doe
John\'\'Doe
John Doe
John\'-Doe
John\' Doe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end