package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`key:(?:\s*('[^']+')*)?(?:\s*('[^']+')*)?(?:\s*('[^']+')*)?`)
var str = `key: 'val1' 'val2' 'val3'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}