$re = '/key:(?:\s*(\'[^\']+\')*)?(?:\s*(\'[^\']+\')*)?(?:\s*(\'[^\']+\')*)?/';
$str = 'key: \'val1\' \'val2\' \'val3\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);