const regex = /[.](?:\S)/iu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[.](?:\\S)', 'iu')
const str = `Я не умею ставить точку .Я не умею ставить точку`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}