$re = '/[.](?:\S)/iu';
$str = 'Я не умею ставить точку .Я не умею ставить точку';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);