import re
regex = re.compile(r"^(?:[0-5]?[0-9]{1,4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-6])$", flags=re.MULTILINE)
test_str = ("-1\n"
"0\n"
"1\n"
"65\n"
"6553\n"
"65534\n"
"65535\n"
"65536\n"
"65537")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")