re = /^(?:[0-5]?[0-9]{1,4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-6])$/m
str = '-1
0
1
65
6553
65534
65535
65536
65537'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end