using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*function\s+(\w+)\s*\(";
string input = @"
function
findMe
(z) {
if (z == true) {
console.log (""Something says Z is true"");
}
}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}