$re = '/^\s*function\s+(\w+)\s*\(/';
$str = '
function
findMe
(z) {
if (z == true) {
console.log ("Something says Z is true");
}
}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);