import re
regex = re.compile(r"\/(\d+).*", flags=re.MULTILINE)
test_str = ("pagePath\n"
"/text/other_text/123-some_other_txet-4571/text.html\n"
"/text/other_text/another_txet/15-some_other_txet.html\n"
"/text/other_text/25189-some_other_txet/45112-text.html\n"
"/text/other_text/text/text/5418874-some_other_txet.html\n"
"/text/other_text/text/text/some_other_txet-4157/text.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")