package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+\.\d+)\s\-\s(\d+.\d+)`)
var str = `1.64 - 2.38`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}