$re = '/(\d+\.\d+)\s\-\s(\d+.\d+)/';
$str = '1.64 - 2.38';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);